Don’t get into Trouble – Allowed UI5 library combinations

SAP is focusing development of sap.m library instead of sap.ui.commons (discontinued). It is obsolete for us during development. They officially state that combining these libraries is not possible, which is other reason not to use this library. The below figure shows you, what can be combined, and what is not safe. As you can see sap.ui.commons and sap.ui.ux3 are the bad guys.

Tip: I managed to use both libraries in SAP WebIDE without errors, however I got into trouble deploying into backend, where sometimes the sap.ui.commons controls were working, sometimes not, dependent, what is loaded so far in the application. “Of course” there was no warning in the SAP WebIDE, when defining XML views using both libraries.

Combinations between sap.m and sap.ui.richtexteditor are allowed only for desktop apps when using version 4 of TinyMCE.