SAP GUI and ADT / ABAP Eclipse Installation on Ubuntu

Tags: ABAP, Eclipse, ADT, Ubuntu, Linux

Short note about SAP GUI and ABAP Developer Tools / Eclipse installation on Ubuntu 18.04.02 LTS

  • Install Ubuntu
  • Download and extract sapmachine-jdk-11.0.3 and javafx-sdk-11 to /opt/java
  • Download SAP GUI Java, and install. Select above folders during installation
  • Eclipse however works properly with Oracle Java(at least for me on Ubuntu 18.04.02). Install it and confgure eclipse.ini to use Java VM Oracle as runtime, but for SAP GUI javafx is needed on latest versions
    -vm
    /usr/lib/jvm/java-11-oracle/bin
    -vmargs
    --module-path=/opt/java/javafx-sdk-11/lib
    --add-modules=ALL-MODULE-PATH